Degraded Performance in Citrix client

Incident Report for Agda PS - Production

Resolved

This incident has been resolved.
Posted Dec 01, 2023 - 08:28 CET

Investigating

Right now some customers are experiencing degraded performance in the citrix client. We are working on the issue.
Posted Nov 17, 2023 - 12:35 CET
This incident affected: Agda PS Client - Citrix Environment.