Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 28, 2025 - 20:00 CEST
Scheduled
We will do a maintenance on our Single Sign On module, this will only affect users that use SSO for Agda PS Web. We estimate that there will be some downtime regarding SSO during this maintenance.
Posted Apr 25, 2025 - 14:56 CEST
This scheduled maintenance affected: Agda PS - Web.