Major outage for Agda PS via Citrix

Incident Report for Agda PS - Production

Resolved

The issue is now resolved and the service is up and running as normal.
Posted Dec 08, 2025 - 15:40 CET

Monitoring

The fix has been deployed and access to Agda PS via Citrix is open again as of 02:00.

We will continue to actively monitor the environment in the upcoming day to ensure everything works as intended.
Posted Dec 05, 2025 - 02:02 CET

Update

The fix is being rolled out and access to Agda PS via Citrix will slowly start reopening for customers.
Posted Dec 04, 2025 - 23:54 CET

Update

A fix is currently underway.
Posted Dec 04, 2025 - 19:38 CET

Update

Work on a fix is still actively ongoing.
Posted Dec 04, 2025 - 12:02 CET

Update

We are continuing to work on a fix for the issues and will update with any progress made.
Posted Dec 04, 2025 - 11:04 CET

Identified

We have an ongoing incident affecting all customers using our Citrix solution.

The issues have been identified but will require all active sessions to be closed, you will get a warning in Citrix before this occurs.

For more info see Visma Community.
Posted Dec 04, 2025 - 09:58 CET
This incident affected: Agda PS - Web and Agda PS Client - Citrix Environment.