Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 17, 2025 - 08:00 CEST
Scheduled
On May 17 between 08:00 and 09:00 CEST there may be short interruptions on the SFTP service due to patching. We will inform here when the maintenance is completed.
Posted May 16, 2025 - 15:48 CEST
This scheduled maintenance affected: Agda PS - SFTP Server.