The issue is now resolved and the service is up and running as normal.
Posted Apr 28, 2025 - 11:22 CEST
Monitoring
We have applied a fix and the service is up and running again. We will keep monitoring to ensure high quality.
Posted Apr 28, 2025 - 08:45 CEST
Investigating
Users are experiencing issues launching applications in the Agda PS Citrix portal. We are currently investigating and will provide more information when available.
Posted Apr 28, 2025 - 07:55 CEST
This incident affected: Agda PS - Web and Agda PS Client - Citrix Environment.