Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 14, 2026 - 20:00 CEST
Scheduled
To ensure the continued security and stability of infrastructure, our Datacenter Network team will be conducting scheduled network maintenance on Citrix Tuesday, 14th July 2026 between 20:00 CEST until 22:00 CEST. During the maintenance window, short disruption may appear.
Posted Jul 14, 2026 - 12:25 CEST
This scheduled maintenance affected: Agda PS Client - Citrix Environment.