Investigating an issue in Agda PS SFTP service

Incident Report for Agda PS - Production

Resolved

The issue is now resolved and the service is up and running as normal.
Posted Dec 04, 2025 - 13:53 CET

Monitoring

The service is up and running again. This issue should be solved for all customers. We will keep monitoring to ensure high quality.
Posted Dec 04, 2025 - 12:39 CET

Investigating

We are currently investigating a service disruption in Agda PS SFTP service. Connections can be very slow or fail. We will provide more information shortly.
Posted Dec 04, 2025 - 10:58 CET
This incident affected: Agda PS - Web and Agda PS Client - Citrix Environment.