Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 26, 2025 - 20:00 CEST
Scheduled
We will be conducting maintenance on our Citrix infrastructure on April 26th between 20:00 CET and 01:00 CET. There will be approximately 2 hours of downtime during this maintenance.
Posted Apr 11, 2025 - 15:17 CEST
This scheduled maintenance affected: Agda PS Client - Citrix Environment.