Investigating problems with Citrix/Agda Client
Incident Report for Agda PS - Production
Resolved
The issue not being able to start the Agda PS client in the Citrix portal seems to be caused by a missing or incorrect "Entrust Root Certification Authority (G2)" certificate on the users computer.

A solution verified by some customers is to download and install the "Entrust Root Certification Authority (G2)" certificate available at https://www.entrust.com/resources/tools/root-certificate-downloads and make sure you have no other version of the same certificate installed.

We advice you to contact your IT department before doing this. If this doesn't solve your issue you can contact Visma via support ticket for further assistance.
Posted Sep 23, 2024 - 12:36 CEST
Investigating
We are currently investigating this issue.
Posted Sep 23, 2024 - 08:51 CEST
This incident affected: Agda PS - Web and Agda PS Client - Citrix Environment.