Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 08, 2026 - 08:00 CEST
Scheduled
Agda PS will be unavailable on Saturday, August 8th, from 08:00 to 12:00 CEST while we apply critical security patches to core infrastructure. We will update this page as soon as the updates are complete and services are fully operational.
Posted Jul 28, 2026 - 15:16 CEST
This scheduled maintenance affected: Agda PS - Web, Agda PS Client - Citrix Environment, Agda PS - SFTP Server, Agda PS - Time terminals, and Agda PS Analys.