Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 27, 2024 - 18:00 CET
Scheduled
On November 27 starting at 18:00 CET, we will update Agda PS. All parts of Agda PS may be offline during the update that may last up to 8 hours. We will inform here when the update is completed.
Posted Nov 25, 2024 - 11:41 CET
This scheduled maintenance affected: Agda PS - Web, Agda PS Client - Citrix Environment, and Agda PS - Time terminals.