Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 28, 2026 - 08:00 CET
Scheduled
On Saturday, March 28th, we will continue performing infrastructure maintenance to enhance security and performance. As a result, the Agda PS SaaS environment will be unavailable starting at 8:00 AM. We estimate the service will be back online by 14:00.
We will inform on the status page when everything is up and running again.
Posted Mar 16, 2026 - 13:48 CET
This scheduled maintenance affected: Agda PS - Web, Agda PS Client - Citrix Environment, and Agda PS - Time terminals.