The issues are now resolved and Agda PS Web is running as normal.
Posted Apr 22, 2025 - 11:27 CEST
Investigating
A small portion of users might be experiencing issues in some parts of Agda PS Web. We are currently investigating and will provide more information when available.
Posted Apr 22, 2025 - 10:15 CEST
This incident affected: Agda PS - Web and Agda PS Client - Citrix Environment.